Prijenosnice - osnovno

Android Prijenosnice
Program za Android Prijenosnice omogućuje da se pomoću Android mobilnog uređaja (telefon, tablet, android skener) vrši unos artikala i količina u dokumente prijenosnice artikala u robno-materijalnom knjigovodstvu ili POS maloprodaji.

Povezivanje mobilnog uređaja se vrši putem WiFi - bežične mreže ili uspostavom VPN mreže pristup može biti sa bilo kojeg mjesta gdje Android uređaj ima pristup mobilnim podacima tj. internetu.
Ako se koristi mobilni telefon, očitanje barkoda se vrši upotrebom kamere telefona, a moguće je koristiti i specijalni uređaj sa ugrađenim čitačem barkoda čime se proces očitanja barkoda značajno pojednostavljuje
Ovi dokumenti se kasnije koriste u kreiranju prijemnica artikala, prodaju - otpremnica, inventure, popis robe, provjeru stanja i sl.

U sve dokumente robno-materijalnog knjigovodstva ili POS maloprodaje/restorana/ljekarni moguće je importirati podatke iz ovako kreiranih prijenosnica artikala.

Kako je prikazano na slici, program ima odgovarajuće module za:

- Rad sa prijenosnicama artikala

- Provjeru i pretraživanje stanja artikala u veleprodaji

- Provjeru i pretraživanje stanja artikala u maloprodaji

- Pregled i pretraživanje artikala

- Prijavu operatera

- Definiranje osnovnih podataka za konekciju sa serverom (definiranje servera i baze podataka, unos osnovnog skladišta/maloprodaje sa kojim se radi)

- Licenciranje programa

Prilikom instalacije programa instalira se prečica u listi programa za pokretanje programa Prijenosnice.

Po pokretanju programa, prvo je potrebno definirati ime SQL servera i baze podataka i broj maloprodaje - tj. profile, korisnik i serverska lozinka za pristup SQL serveru, te osnovni broj maloprodaje.

Moguće je definirati neograničeni broj profila koji se kasnije jednostavno biraju po potrebi.

Također je potrebno izvršiti licenciranje programa, te se onda može nastaviti sa radom.

Da bi operater mogao raditi sa programom, potrebno je izvršiti prijavu operatera. Podaci o operateru i prava za rad se unose u programu Robno-materijalno ili POS maloprodaja/POS Restoran ili POS Ljekarne.
Ako se ispravno prijavi operater i ima pravo rada sa prijenosnicama i odabranim skladištem, moguć je rad sa prijenosnicama ili pregled stanja artikala.

Glavni meni aplikacije

Korištenjem opcija u glavnom meniju aplikacije, moguće je pokrenuti postavke servera, licenciranje i postavke boja u programu.
Opcije Postavke servera i licenciranje su identične osnovnim opcijama na tipkama.

Za izbor boja u aplikaciji, predvidjeli smo mogućnost jednostavnog izbora crvene, plave, zelene i crne boje.

Ako se izabere plava boja, sve tipke i dr. su obojeni plavom bojom i sl. kako je prikazano na slici ispod.

Program će zapamtiti odabranu boju i u nastavku, a i po ponovnom pokretanju programa, automatski će se koristiti postavljena boja.

Ako korisnik želi neku svoju posebnu boju, potrebno je izabrati opciju Prilagođena boja iz menija, te se na ekranu pojavi mogućnost izbora boje po želji, što je prikazno na sljedećoj slici ispod.

Rad sa biometrijom je opisan ovdje.

Ako se izabere plava boja, sve tipke i dr. su obojeni plavom bojom i sl. kako je prikazano na slici lijevo.

Izbor prilagođene boje je jednostavan.

Prvo je potrebno izabrati osnovnu boju iz spektra desno, pa onda izabrati detaljnu boju iz spekra lijevo, tapom na željenu boju.

Kada je korisnik zadovoljan izborom, potrebno je pritisnuti tipku U REDU.

Program će zapamtiti odabranu boju i u nastavku rada, a i po ponovnom pokretanju programa, automatski će se koristiti postavljena boja.

KOMP-ING d.o.o.
Stjepana Radića 3, 72250 Vitez
Tel/fax: +387 30 710-711, 712-710, 712-751, 713-791
Internet: www.komping.com E-mail: komping@komping.com
PDV ID broj: 236021560004, ID broj: 4236021560004 Por.broj: 19070002
Upis u sud: Viši sud Travnik br.U/I 186/200 br. 1-860.
Žiro račun: 3060410000000580 Hypo Alpe Adria Bank d.d. Mostar, P.J. Vitez


Prijenosnice - rad sa prijenosnicama

Rad sa prijenosnicama

Izborom opcije za rad sa prijenosnicama artikala ulazi se u dio programa za rad sa prijenosnicama.

U programu je omogućeno:
- filtriranje prijenosnica prema opsegu datuma
- pregled svih prijenosnica za zadani ospeg datuma
- unos/izmjena/brisanje zaglavlja prijenosnice
- unos stavki prijenosnice

Na vrhu ekrana je prikazan opseg datuma prikazanih prijenosnica za koji se prikazuju prijenosnice. Početni datum je postavljen na početak tekuće godine, a za konačni datum je postavljen tekući datum. Program pamti trenutno postavljeni filter opsega datuma dok se nalazite u radu sa prijenosnicama.

Korisnik jednostavnim tapom na jedan od datuma može postaviti opseg datuma koji želi, što je prikazano na slijedećoj slici.
Tapom na neki datum, prikaže se unos datuma, te tada korisnik može izabrati datum koji želi tapom na određeni dan u mjesecu ili koristeći strelice na vrhu lijevo ili desno od prikazanog mjeseca, kretati se po mjesecima.

Tapom na jedan dokument prijenosnice prikazan u listi, pokreće se proces izmjene podataka o prijenosnici.

U tom dijelu je moguće i izbrisati unesenu prijenosnicu. Ako ima unesenih stavki neće biti moguće obrisati .

U listi podataka o prijenosnicama, prikazuju se broj, ime firme, datum prijenosnice, opis 1 i opis 2, te status završenosti i da li je prijenosnica predviđena za elektronsku razmjenu podataka (za EDI).

Nova prijenosnica se upisuje pritiskom na plivajuću ikonu + Nova pri dnu ekrana.

Filtriranje-pretraživanje prijenosnica

Lijevo je prikazana mogućnost izbora datuma.

Korisnik jednostavnim tapom na jedan od datuma može postaviti opseg datuma koji želi, što je prikazano na slijedećoj slici.
Tapom na neki datum, prikaže se unos datuma, te tada korisnik može izabrati datum koji želi tapom na određeni dan u mjesecu ili koristeći strelice na vrhu lijevo ili desno od prikazanog mjeseca, kretati se po mjesecima.

Kada se tapne na neku prijenosnicu iz liste ili se tapne na tipku + na plivajućoj tipki za unos nove prijenosnice, prikažu se podaci o selektiranoj ili novoj prijenosnici.

Podaci koji se unose u zaglavlje prijenosnice su:

- Broj prijenosnice- program automatski ponudi slijedeći broj u slučaju nove prijenosnice.

- Kupac (komitent) - potrebno unijeti komitenta, moguće je pretraživanje interaktivno prema dijelu naziva komitenta.

- Datum prijenosnice. Moguće je izabrati iz kalendara tapom na datum.

- Opis1 i Opis2 - dva reda opisa

Ukoliko se unese broj narudžbe u Opis 2, onda će program provjeravati za svaku stavku da li unesena šifra artikla stavke prijenosnice postoji u narudžbi robe dobavljaču i da li je količina odgovarajuća, čime je moguće kontrolirati unos stavki pri prijemu robe.

Kada se upišu ovi podaci, izborom tipke Spremi spremaju s podaci o prijenosnici i prelazi se u mod za rad sa stavkama prijenosnice.

Korištenjem tipke Obriši, moguće je obrisati zaglavlje prijenosnice. Ako postoje unesene stavke prijenosnice, dokument neće moći biti obrisan, te se o tome izdaje odgovarajuća greška. Tipka Obriši se ne vidi ako se unosi nova prijenosnica.

Izborom tipke sa strelicom nazad u lijevom vrhu ekrana, prekida se sa unosom podataka o toj prijenosnici i vraća na prikaz zaglavlja prijenosnica.

Ako se želi obrisati uneseni podatak, dovoljno je tapnuti na tipku X na kraju polja za unos podataka.

Izbor komitenta je veoma jednostavan.

Tapom na naziv kupca, moguće unijeti dio teksta naziva kupca. Kada se unese više od dva znaka, interaktivno se u padajućem meniju pojavlju svi kupci koji u nazivu imaju uneseni tekst.

Naziv kupca unosimo sve dok ne nađemo željenog kupca u lisit ili skrolamo sve komitente iz padajuće liste.
Kada se tapne na željenog kupca, njegov naziv i šifra kupca u zagradama se prenesu u polje naziva kupca.

Ukoliko se želi ponoviti pretraživanje, dovoljno je ponoviti postupak.

Rad sa stavkama prijenosnica
Kada se spreme podaci o zaglavlju prijenosnice tapom na tipku Spremi, prikazuje se forma za rad sa stavkama prijenosnica.

Postoje dva načina unosa stavke: ručnim unosom šifre artikla ili korištenjem skenera barkoda.

U vrhu forme postoji forma za unos šifre ako se želi unijeti ručno. Proces je identičan kao i pri unosu šifre komitenta u zaglavlju prijenosnice.

Tapom na naziv artikla, uključuje se tastatura, te unosom više od dva znaka naziva artika, interaktivno se u padajućem meniju pojavlju svi artikli koji u nazivu imaju uneseni tekst.

Naziv artikla unosimo sve dok ne nađemo željeni artikal u listi ili skrolamo sve artikle iz padajuće liste.
Kada se tapne na željeni artikal, njegov naziv i šifra artikla u zagradama se prenesu u polje naziva artikla. Time je izbor artikla završen.

Ukoliko se želi ponoviti pretraživanje, dovoljno je ponoviti postupak.

U formi je omogućen unos barkoda i količine.

Barkod je moguće unositi ručno ili putem skenera preko kamere telefona ili specijalnog uređaja za skeniranje.

Ako se barkod unosi ručno, potrebno je unijeti žaljeni barkod i tapnuti na tipku Nađi. Ako se pronađe artikal sa tim barkodom, naziv artikla i šifra će se pojaviti u gornjem dijelu gdje su podaci o artiklu.

Ako se želi koristiti skeniranje barkoda preko kamere telefona, potrebno je tapnuti na tipku Scan i skenirati barkod. Kada se barkod skenira i uspješno pronađe šifra artikla, pojavlju se tipka Spremi kojom možemo spremiti stavku. Prije toga treba unijeti željenu količinu.

Inače tipka Spremi se pojavi nakon ručnog unosa šifre, skeniranja na bilo koji način, te se onda ostavlja mogućnost da se unese količina. Onda se pritiskom na tipku Spremi izvrši provejra svih podataka i spremi stavka prijenosnice. Ukoliko je uključena opcija u meniju Ponovi skeniranje, poslije skeniranja barkoda stavka prijenosnice se automatski sprema sa unesenom količinom bez pojave ove tipke Spremi.

Korištenjem tipke + moguće je povećati količinu za 1, a tipke - smanjiti količinu za 1. TIpka 1 služi za postavljanje količine na 1.

Ako se koristi specijalni skener, potrebno se uvjeriti da je kursor u polju za unos barkoda (što se automatski postavi pri ulasku u ovu formu). Kada se skenira barkod, pokuša se pronaći šifra artikla te ako se pronađe artikal sa tim barkodom, naziv artikla i šifra će se pojaviti u gornjem dijelu gdje su podaci o artiklu, te se pojavi tipka Spremi. Tada je moguće unijeti količinu i spremiti stavku. Ovdje ponašanje programa ovisi o postavke Ponovi skeniranje u meniju što će biti opisano u nastavku ovih uputa.

Ako se ne pronađe artikal sa unesenim barkodom, izdaje se odgovarajuća poruka da artikal nije pronađen, te se klikom na OK nastavlja rad sa programom.

Bitno je napomenuti da program prepoznaje težinski barkod artikla, a to su artikli čiji barkod počinje sa 21 - 29. Prvih 7 cifara predstavljaju barkod artikla koji treba unijeti u barkod, a sljedećih 5 cifara prestavljaju težinu u gramima. Po čitanju ovog barkoda, program pokuša pronaći barkod sa prvih 7 cifara, a za količinu postavi količinu u gramima podijeljenu sa 1000 tj. u kg.

Ukoliko se unese broj narudžbe u Opis 2 u zaglavlju prijenosnice (program provjeri da li je u opisu 2 unesen broj (bez bilo kakvih drugih znakova)), onda će program provjeravati za svaku stavku da li unesena šifra artikla stavke prijenosnice postoji u toj narudžbi robe dobavljaču i da li je količina odgovarajuća, čime je moguće kontrolirati unos stavki pri prijemu robe.

Ako taj artikal ne postoji, program izda upozorenje i pita da li se stavka prijenosnice ipak želi spremiti.
Ako artikal postoji, ali je unesena količina različita od stavke u narudžbi robe, prikaže se upozorenje o unesenoj količini i količinu u narudžbi robe i traži potvrda unosa stavke.
Ako je ista količina, stavka se samo spremi bez upozorenja, što znači da nije potrebna potvrda, jer je količina ispravna.

Tapom na neku stavku prijenosnice, omogućen je prikaz stanja u veleprodaji ili maloprodaji za šifru i naziv artikla stavke.
Prikazuje se stanje u veleprodaji ili maloprodaji ovisno o postavke prikaza stanja skl. u veleprodaji ili maloprodaji u stavkama prijenosnice.
Program automatski postavi šifru artikla i naziv artikla u filteru stanja, a u tom dijelu je onda moguće pretraživanje i za ostale šifre, naziv i barkod, kao i kod prikaza stanja u skladištu - maloprodaji.
Ovim je olakšan pregled stanja, da se ne mora izlaziti iz rada sa stavkama prijenosnica ako se treba pogledati stanje, posebno ako ima više cijena po pojedinoj šifri artikla.

Postavke pri radu sa stavkama

U gornjem desnom dijelu forme za rad sa stavkama prijenosnica nalazi se tipka sa tri vertikalne točkice, čijim tapom se otvara meni za postavke.

Ponovi skeniranje

Ova opcija omogućava da se uključi automatsko spremanje uspješno pronađene šifre artikla sa trenutno unesenom količinom u stavku prijenosnice. Kada se stavka spremi, program resetira sva polja, količinu postavi na 1, te automatski postavi kursor za unos novog barkoda, te ako je pokrenuto skeniranje preko tipke Scan za očitanje barkoda preko kamere telefona, pokrene automatski kameru za novo očitanje. Ovo je korisno kada se radi inventura artikala, te se po izvršenom skeniranju odmah nastavlja dalje sa radom i unosom stavke.

Sumiraj količinu za iste stavke

Ova opcija omogućava da se po uspješnom pronalasku šifre na osnovu barkoda, pokuša pronaći do sada unesena stavka prijenosnice sa istom šifrom, te ako se nađe, samo se doda unesena količina. Ako se ne pronađe stavka sa istom šifrom, doda se nova stavka.

Ne koristi težinski barkod 21-29

Ukoliko se ne koristi težinski barkod, a postoje neke šifre koje počinju sa 21 do 29, onda je potrebno uključiti ovu opciju, čime se učitani barkod ne tretira kao težinski barkod.

Prikaz stanja u skl./maloprodaji

Ukoliko se želi prikazivati ukupno stanje u tekućem skladištu/maloprodaji u prikazu stavki prijenosnice, onda je potrebno uključiti ovu opciju. Koje stanje će se prikazivati (veleprodaj - maloprodaja), ovisi o postavkama u naredne dvije stavke menija.

Prikaz stanja i nar. u maloprodaji

Ova opcija definira da se prikazuje stanje iz maloprodaje u stavkama prijenosnice i provjeravaju stavke narudžbi robe dobavljaču unesenih u POS maloprodaji/restoranu/ljekarni.

Prikaz stanja i nar. u veleprodaji

Ova opcija definira da se prikazuje stanje iz veleprodaje u stavkama prijenosnice i provjeravaju stavke narudžbi robe dobavljaču unesenih u robno-materijalnom knjigovostvu.

Prikaz zadnje nabavne cijene

Ova opcija definira da li će se u stavkama prijenosnice prikazivati zadnja nabavna cijena iz šifarnika artikala.
Unos šifre artikla ručno

Šifra artikla se može unijeti i ručno.

Tapom na naziv artikla, uključuje se tastatura, te unosom više od dva znaka naziva artika, interaktivno se u padajućem meniju pojavlju svi artikli koji u nazivu imaju uneseni tekst.

Naziv artikla unosimo sve dok ne nađemo željeni artikal u listi ili skrolamo sve artikle iz padajuće liste.
Kada se tapne na željeni artikal, njegov naziv i šifra artikla u zagradama se prenesu u polje naziva artikla. Time je izbor artikla završen.

Ukoliko se želi ponoviti pretraživanje, dovoljno je ponoviti postupak.

Ako se želi obrisati uneseni podatak, dovoljno je tapnuti na tipku X na kraju polja za unos podataka.

Brisanje stavke prijenosnice

Nije moguće ručno mijenjanje stavke prijenosnice, nego ju je moguće samo obrisati, pa unijeti ponovno.Ovo je napravljeno radi jednostavnosti rada.

Brisanje stavke je moguće pokrenuti pritiskom na crvenu tipku X koja je prikazana za svaku stavku.

Potom se na ekranu pojavi dijalog za potvrdu brisanja stavke.

Provjera postojanosti artikla u narudžbama robe dobavljaču

Ukoliko se unese broj narudžbe u Opis 2 u zaglavlju prijenosnice (program provjeri da li je u opisu 2 unesen broj), onda će program provjeravati za svaku stavku da li unesena šifra artikla stavke prijenosnice postoji u toj narudžbi robe dobavljaču i da li je količina odgovarajuća, čime je moguće kontrolirati unos stavki pri prijemu robe.

Ako taj artikal ne postoji, program izda upozorenje i pita da li se stavka prijenosnice ipak želi spremiti, što je prikazano na slici lijevo.
Ako artikal postoji, ali je unesena količina različita od stavke u narudžbi robe, prikaže se upozorenje o unesenoj količini i količinu u narudžbi robe i traži potvrda unosa stavke, što je prikazano na slici lijevo.

Ako je ista količina, stavka se samo spremi bez upozorenja, što znači da nije potrebna potvrda, jer je količina ispravna.


Prijenosnice - stanje

Stanje u veleprodaji i maloprodaji

Izborom opcije za rad sa pregledom stanja kako u veleprodaji tako i u maloprodaji u glavnom programu, ulazi se u dio programa za rad sa pregledom i pretraživanjem stanja artikala.

Stanje (lager listu) je moguće pretraživati po dijelu naziva artikala interaktivno, tj. kada se unesu dva ili više od dva znaka, automatski se prikazuje stanje artikal koji u nazivu sadrže uneseni dio teksta bilo gdje u nazivu artikala.

Ako se želi pretraživati po dijelu šifre artikla ili po dijelu barkoda artikla, potrebno je unijeti željeni tekst ili brojeve, te onda tapnuti tipku Filtriraj.

Ako se želi obrisati uneseni podatak za pretraživanje, dovoljno je tapnuti na tipku X na kraju polja za unos podataka.

Također je moguće skenirati barkod putem skenera preko kamere uređaja upotrebom tipke Scan, te se po očitanju barkoda tapom na tipku Filtriraj pokreće pretraživanje i prikaže stanje artikla koji imaju uneseni barkod.
Pretražuje se kako po osnovnom barkodu, tako i po dodatnim barkodovima po artiklima.

Ako se koristi specijalni čitač barkoda, treba se uvjeriti da je kursor postavljen na polje Barkod, što je i osnovna postavka pri ulasku u ovu formu.Po očitanju barkoda, automatski se pokreće prikaz stanja za zadati barkod. U skeneru treba postaviti da se na kraju dodaju znakovi za novi red, što će vam pomoći naši djelatnici.

Prikazane podatke je moguće skrolati na dole klizanjem prstom odozdo-gore ili na gore, klizanjem prstom odozgo-dole.

Prikazane podatke je moguće sortirati prema nazivu ili prema šifri artikla upotrebom opcija u meniju (tipka u zaglavlju gore desno), što je objašnjeno u nastavku uputa.

U podacima o artiklu prikazuje se naziv, šifra, količina na stanju, jedinica mjere, te cijena na stanju.

U zaglavlju podataka se prikaže ukupna suma količine i vrijednosti za trenutno postavljeni filter.

Bitno je napomenuti da se prikaže stanje u veleprodaji ili maloprodaji samo za skladišta-maloprodaje za koje korisnik ima pravo raditi, što se postavlja u odgovarajućim programima robno-materijalnog ili POS maloprodaji - POS restoranu - POS ljekarni.

Lijevo je prikazan ekran za stanje u maloprodaji.

Bitno je napomenuti da se broj maloprodaje unosi generalno za program u podacima o profilima - server-baze podataka i broj skladišta-maloprodaje.

Ukoliko nema podataka za zadani filter, prikaže se tekst Nema podataka.

Klikom na meni u gornjem desnom kutu forme, pokreće se meni sortiranja podataka, kako je prikazano na slici lijevo.

Podatke je moguće sortirati prema nazivu ili prema šifri artikla. Ova postavka se pamti i po svakom pokretanju opcije postavlja se zadnja korištena opcija.


Prijenosnice - artikli

Pregled i pretraživanje artikala

Izborom opcije za rad sa artikalima u glavnom programu, ulazi se u dio programa za rad sa pregledom i pretraživanjem artikala.

Artikle je moguće pretraživati po dijelu naziva artikala interaktivno, tj. kada se unesu dva ili više od dva znaka, automatski se prikazuju artikli koji u nazivu sadrže uneseni dio teksta bilo gdje u nazivu artikala.

Ako se želi pretraživati po dijelu šifre artikla ili po dijelu barkoda artikla, potrebno je unijeti željeni tekst ili brojeve, te onda pritisnuti tipku Filter.Bitno je napomenuti da se uzimaju svi uneseni podaci za pretraživanje artikala (dio naziva, dio šifre i dio barkoda) koji su uneseni.

Također je moguće skenirati barkod putem skenera preko kamere uređaja, te se po očitanju barkoda automatski pokreće pretraživanje i prikaže artikal ili artikli koji imaju uneseni barkod.
Pretražuje se kako po osnovnom barkodu, tako i po dodatnim barkodovima po artiklima.

Ako se koristi specijalni čitač barkoda, treba se uvjeriti da je kursor postavljen na polje Barkod, što je i osnovna postavka pri ulasku u ovu formu.

Prikazane podatke je moguće skrolati na dole klizanjem prstom odozdo-gore ili na gore, klizanjem prstom odozgo-dole.

Prikazane podatke je moguće sortirati prema nazivu ili prema šifri artikla upotrebom opcija u meniju (tipka u zaglavlju gore desno), što je objašnjeno u nastavku uputa.

U podacima o artiklu prikazuje se naziv, šifra, barkod, jedinica mjere, te upisane VPC i MPC iz šifarnika artikala.

Ako se želi obrisati uneseni podatak, dovoljno je tapnuti na tipku X na kraju polja za unos podataka.

Klikom na meni u gornjem desnom kutu forme, pokreće se meni sortiranja podataka, kako je prikazano na slici lijevo.

Podatke je moguće sortirati prema nazivu ili prema šifri artikla. Ova postavka se pamti i po svakom pokretanju opcije postavlja se zadnja korištena opcija.


Prijenosnice - prijava operatera

Prijava operatera
Prilikom pokretanja programa i ukoliko je ispravno uneseno ime servera i baze podataka, a prije početka rada, potrebno se prijaviti u program.

Ako se pokrene neka od opcija programa, a operater nije prijavljen, automatski se pokreće ova forma za logiranje - prijavu operatera, kao što je prikazano na slici lijevo.

Potrebno je unijeti ime operatera i lozinku. Ovi podaci se definiraju u programu robno-materijalnog knjigovodstva ili POS maloprodaje - restorana - ljekarni.

Važno je napomenuti da prijavljeni operater mora imati prava za rad sa prijenosnicama - a dovoljno je za mobilnog operatera prijaviti pravo za unos nove prijemnice.

Po izboru tipke Prijava operatera, program provjerava ispravnost prijave za tog operatera, te ako nije ispravno ime i/ili lozinka, upozorava se o grešci i ponovno traži prijava.

Ukoliko se pritisne tipka Prekid - izlaz, prekida se sa logiranjem tj. izlazi se iz ove forme prijava, ali onda nije moguće raditi sa prijenosnicama i drugim opcijama.

Ukoliko je korisnik prijavljen, te se promijeni profil konekcije (drugi server-baza-broj skladišta), program provjeri da li je ista lozinka prijavljenog operatera sa novim podacima o serveru-bazi, te ako je ista nema potrebe za ponovnom prijavom korisnika.

Ako se želi pregledati unesena lozinka, dovoljno je tapnuti na desnu ikonu oka na polju za unos lozinke. Onda će se lozinka otkriti da korisnik može projevjeriti što je unio. Ponovnim tapom na sliku sa okom, sakriva se unesena lozinka.

Ako se želi obrisati uneseni operater, dovoljno je tapnuti na tipku X na kraju polja za unos podataka.

Korištenje biometrije
Otisak prsta i prepoznavanje lica

Ukoliko je na uređaju omogućena upotreba biometrije - prijava korištenjem otiskom prsta ili prepoznavanjem lica, poslije uspješne prijave korisnika program pita da li se želi koristiti biometrija za lakšu prijavu.
Potvrdnim odgovorom sačuvaju se trenutni podaci o prijavljenom operateru sa biometrijskom prijavom na uređaj.

Korištenjem biometrijske prijave na uređaju, olakšava se prijava operatera, bez nepotrebnog stalnog unosa imena operatera i lozinke.

Slijedeći put kada se pokrene prijava operatera, program će pokrenuti biometrijsku autentifikaciju na uređaju, te ako je uspješna prijava, prijaviti će se povezani operater.

Program će provjeriti da spremljena lozinka operatera pri uspostavi biometrije odgovara lozinci operatera u bazi podataka, te ako je ispravna, nastaviti će sa radom sa tim operaterom.

Ako nije ista lozinka, program će preusmjeriti korisnika na ponovnu prijavu klasičnim putem i omogućiti opet povezivanje novog operatera sa biometrijom.

Korisniku su omogućena tri pokušaja biometrijske prijave, nakon čega se operater preusmjerava na običnu prijavu unosom imena i lozinke.

U glavnom meniju programa, dodana je nova opcija mogućnosti uključenja/isključenja prijave biometrijom.

Ako je korisnik uvezao biometriju sa operaterom, onda je opcija uključena.

Ako se isključi ova opcija (klikne na nju kada je uključena), onda se obrišu svi uvezani podaci operatera sa biometrijom i koristi se redovna prijava operatera.

Ako se želi biometrija ponovo uključiti, klikom na ovu isključenu stavku, program omogućuje ponovno korištenje biometrije ukoliko je operater prijavljen.

Ukoliko nije, opcija se ostavlja isključena, ali operater može jednostavno ponoviti postupak uvezivanja biometrije redovnom prijavom kako je gore opisano.


Prijenosnice - servisne postavke

Definiranje profila servera i baza podataka i broja skladišta-maloprodaje

Da bi progam ispravno radio i povezivao se sa glavnim serverom i bazom podataka, potrebno je uređaj uvezati u bežičnu ili VPN mrežu, te definirati ime servera i baze podataka, podatke za pristup SQL serveru (korisničko ime i lozinku za server, s tim što program automatski postavi osnovne postavke), kao i osnovi broj skladišta/maloprodaje sa kojim se radi.

Administratori sustava trebaju odraditi povezivanje uređaja sa WiFi mrežom ili uspostaviti VPN vezu preko interneta, te unijeti ime servera i baze podataka, mijenjati samo po potrebi.

Da bi se smanjila potreba stalnog unosa broja skladišta/maloprodaje za svaki dokument, u programu se šifra skladišta/maloprodaje sa kojom se radi unosi samo jednom i to u ovoj formi.

Ukoliko se radi sa više skladišta/maloprodaja, potrebno je upisati potrebne podatke o skladištu/maloprodaji i spremiti podatke pod novim imenom profila.

Ukoliko se želi preći na rad sa drugim skladištem/maloprodajom, potrebno je ući u ovu formu, izabrati odgovarajući profil, te tapnuti na tipku Spremi profil i postavke, i onda se vratiti nazad korištenjem tipke sa strelicom koja se nalazi na gornjem lijevom kutu ekrana..

Da bi operater mogao ući u prijenosnice i raditi sa njima, administrator mu mora dati pravo rada sa tim skladištem.

Da bi korisnik provjerio da li je moguće uspostaviti vezu sa serverom-bazom, moguće je tapnuti tipku Test, te će se izdati odgovarajuća poruka da li je moguća veza sa serverom-bazom. Pritikom na tipku Test se također prilagodi i baza podataka na zadnju verziju da bi bila dostupna sva potrebna polja.

Također program automatski provjeri da li je moguća veza sa serverom-bazom i ako se može uspostaviti veza, u listi profila na dnu se prikaže zelena ikona uspostave veze, a ako se ne može uspostaviti veza, prikazana je crvena prekrižena ikona.
Testirano vrijeme odziva je 3 sekunde.
Lijevo je prikazana slika podataka za jedan server-bazu i broj maloprodaje 1.

Kod unosa naziva sql servera, preporučljivo je koristiti IP adresu SQL servera, na koju je obvezno dodati ime porta na kojem SQL server sluša. U većini slučajeva je to port 1433, pa se na ime servera treba dodati sufiks :1433 tj. dvotačka i broj porta.

Ukoliko na serveru postoji više instanci SQL servera, potrebno je unijeti i naziv instance u polje predviđeno za naziv instance.
Ako je na serveru instaliran samo jedan SQL server, nema potrebe unositi naziv instance iako postoji.

Ime baze podataka mora postojati na SQL serveru, a korisničko ime i lozinku za pristup SQL serveru možete dobiti od svog administratora ili Komp-inga, ovisno tko je instalirao SQL server.
Za korisničko ime pristupa SQL serveru se najčešće koristi ime sa.

Komp-ing osnovna lozinka se automatski postavi ako je prazna i ne treba je mijenjati, ako nije mijenjana po osnovnoj instalaciji.

U slučaju potrebe, slobodno kontaktirajte djelatnike komp-ing-a za pomoć oko ovih podataka.

Ako se želi obrisati uneseni podatak, dovoljno je tapnuti na tipku X na kraju polja za unos podataka.


Prijenosnice - licenciranje

Licenciranje
LIcenciranje će odraditi naši djelatnici i malo se razlikuje od ovog opisa, ali možda ćemo nešto mijenjati u budućnosti.

Program je potrebno licencirati da bi se moglo raditi sa njim. Prvo je potrebno spojiti se na bazu podataka, te potom pokrenuti licenciranje programa.

Na ekranu se pojavi ekran prikazan lijevo, sa osnovnim podacim o imenu firme, imenu uređaja, ID-u uređaja i registarskom broju.

Podatke potrebne za licenciranje Komp-ing-u je moguće poslati putem e-mail, tapom na tipku Pošalji zahtjev na e-mail, a u slučaju da uređaj nema instaliran neki program sa e-mail klijentom, podatke je moguće poslati i putem bluetooth-a ili nekog drugog programa koji može poslati datoteku sa podacima, tapom na tipku Pošalji zahtjev bluetooth-om ili sl.. Oko ovog dijela pomoći će vam naši djelatnici.

Kada dobijete licencu, potrebno je unijeti licencu u odgovarajući dio sa licencom i spremiti licencu. te kada se unese licenca, ukoliko je ispravna, program će je spremiti i moguće je krenuti sa radom, inače se daje poruka o grešci.

Kada se unese ispravna licenca, iz osnovnog ekrana se ukloni tipka za unos licence, ali je ovaj proces moguć pokrenuti izborom opcije Licenciranje iz menija glavnog programa.

Ako se želi obrisati unesena licenca, dovoljno je tapnuti na tipku X na kraju polja za unos podataka.